You are here: Home Vista News Watch Neowin.net - Microsoft pushes WLMessenger 8.1 upgrade: security reasons

Neowin.net - Microsoft pushes WLMessenger 8.1 upgrade: security reasons

Microsoft forces you to install new software. What they consider security isn't necessarily security for you.

  • Imported on: 14 Sep 2007, 14:00
  • Created on: 14 Sep 2007, 17:48